Skip to content
Microsoft Dynamics 365

When installing cumulative update on 8.0.4 on Tier II sandbox environment you may experience the error:

“The running command stopped because the preference variable “ErrorActionPreference” or common parameter is set to Stop: Unable to resolve dependency ‘dynamicsax-applicationfoundationformadaptor’.”

This due to the fact that there is a X++ code released in Demodatasuite model where we changed the class SalesOrdersCleanup.

On Tier II there are no Demodatasuite model or any related models installed and this is why we are getting error. The way to go is to exclude the model from the build definition https://docs.microsoft.com/en-us/dynamics365/unified-operations/dev-itpro/dev-tools/exclude-test-packages

We're always looking for feedback and would like to hear from you. Please head to the Dynamics 365 Community to start a discussion, ask questions, and tell us what you think!

Join the conversation

Loading comments...